#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[ ]*\d+$"
Local $sString = " 132456" & @CRLF & _
" 4654" & @CRLF & _
"9798" & @CRLF & _
"97987abc" & @CRLF & _
"8723674 7832" & @CRLF & _
"123..5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")