import re
regex = re.compile(r"^[ ]*\d+$")
test_str = (" 132456\n"
" 4654\n"
"9798\n"
"97987abc\n"
"8723674 7832\n"
"123..5")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")