$re = '/^[ ]*\d+$/';
$str = ' 132456
4654
9798
97987abc
8723674 7832
123..5';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);