const regex = new RegExp('^[ ]*\\d+$', '')
const str = ` 132456
4654
9798
97987abc
8723674 7832
123..5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}