using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![;].*)\bcomment\b([:])";
string input = @"
FileAppend x%x% y%y% w%w% h%h% comment: %commentV% `n, *
;FileAppend x%x% y%y% w%w% h%h% comment: %commentV% `n, *
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}