re = /(?<![;].*)\bcomment\b([:])/m
str = '
FileAppend x%x% y%y% w%w% h%h% comment: %commentV% `n, *
;FileAppend x%x% y%y% w%w% h%h% comment: %commentV% `n, *
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end