const regex = /(?<![;].*)\bcomment\b([:])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![;].*)\\bcomment\\b([:])', 'gm')
const str = `
FileAppend x%x% y%y% w%w% h%h% comment: %commentV% \`n, *
;FileAppend x%x% y%y% w%w% h%h% comment: %commentV% \`n, *
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}