$re = '/(?<![;].*)\bcomment\b([:])/m';
$str = '
FileAppend x%x% y%y% w%w% h%h% comment: %commentV% `n, *
;FileAppend x%x% y%y% w%w% h%h% comment: %commentV% `n, *
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);