const regex = /(^.*?\.[a-zA-Z]+)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.*?\\.[a-zA-Z]+)(.*)$', 'gm')
const str = `myApp.ComboPlaceHolderLabel,
myApp.GridTitleLabel);
myApp.SummaryLabel + '</b></div>');
myApp.NoneLabel + ')') + '</label></div>';
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);