$re = '/(^.*?\.[a-zA-Z]+)(.*)$/m';
$str = 'myApp.ComboPlaceHolderLabel,
myApp.GridTitleLabel);
myApp.SummaryLabel + \'</b></div>\');
myApp.NoneLabel + \')\') + \'</label></div>\';
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;