import re
regex = re.compile(r"(^.*?\.[a-zA-Z]+)(.*)$", flags=re.MULTILINE)
test_str = ("myApp.ComboPlaceHolderLabel,\n"
"myApp.GridTitleLabel);\n"
"myApp.SummaryLabel + '</b></div>');\n"
"myApp.NoneLabel + ')') + '</label></div>';\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)