package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^ISA(?:[^*]*[*][^*]*){8}\*(\d+)\* `)
var str = `ISA *00* *00* *ZZ*SOME STRING *ZZ*99999999 *130605* 2239*|*00501*000000001*0*P*>
REF*TJ*12345677*
REF*PQ*23432211
LX*1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}