re = /^ISA(?:[^*]*[*][^*]*){8}\*(\d+)\* /
str = 'ISA *00* *00* *ZZ*SOME STRING *ZZ*99999999 *130605* 2239*|*00501*000000001*0*P*>
REF*TJ*12345677*
REF*PQ*23432211
LX*1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end