import Foundation
let pattern = #"^ISA(?:[^*]*[*][^*]*){8}\*(\d+)\* "#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ISA *00* *00* *ZZ*SOME STRING *ZZ*99999999 *130605* 2239*|*00501*000000001*0*P*>
REF*TJ*12345677*
REF*PQ*23432211
LX*1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}