use strict;
my $str = 'ISA *00* *00* *ZZ*SOME STRING *ZZ*99999999 *130605* 2239*|*00501*000000001*0*P*>
REF*TJ*12345677*
REF*PQ*23432211
LX*1';
my $regex = qr/^ISA(?:[^*]*[*][^*]*){8}\*(\d+)\* /p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}