const regex = /^[A-Z0-9a-z\-/'\?:\+À-ÖØ-öø-ÿĀ-ķĹ-ňŊ-žΆΈ-ΊΌΎ-ΡΣ-ώЁ-ЌЎ-яё-ќўџѪѫѴѵҐґ ]+$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z0-9a-z\\-\/\'\\?:\\+À-ÖØ-öø-ÿĀ-ķĹ-ňŊ-žΆΈ-ΊΌΎ-ΡΣ-ώЁ-ЌЎ-яё-ќўџѪѫѴѵҐґ ]+$', 'g')
const str = `Ó`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}