$re = '/^[A-Z0-9a-z\-/\'\?:\+À-ÖØ-öø-ÿĀ-ķĹ-ňŊ-žΆΈ-ΊΌΎ-ΡΣ-ώЁ-ЌЎ-яё-ќўџѪѫѴѵҐґ ]+$/';
$str = 'Ó';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);