re = /^[A-Z0-9a-z\-\/'\?:\+À-ÖØ-öø-ÿĀ-ķĹ-ňŊ-žΆΈ-ΊΌΎ-ΡΣ-ώЁ-ЌЎ-яё-ќўџѪѫѴѵҐґ ]+$/
str = 'Ó'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end