import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " ^ # anchors the expression to the beginning\n"
+ " (?=[^a-z]*[a-z]) # not lowercase, followed by lowercase\n"
+ " (?=[^A-Z]*[A-Z]) # not UPPERCASE, followed by UPPERCASE\n"
+ " (?=\\D*\\d) # not a digit, followed by a digit\n"
+ " .{8,} # at least 8 characters long\n"
+ " $ # anchor the expression to the end\n";
final String string = "strong?\n"
+ "WeaK1234\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}