// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx) ^ # anchors the expression to the beginning
(?=[^a-z]*[a-z]) # not lowercase, followed by lowercase
(?=[^A-Z]*[A-Z]) # not UPPERCASE, followed by UPPERCASE
(?=\D*\d) # not a digit, followed by a digit
.{8,} # at least 8 characters long
$ # anchor the expression to the end
").unwrap();
let string = "strong?
WeaK1234
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}