$re = '/ ^ # anchors the expression to the beginning
(?=[^a-z]*[a-z]) # not lowercase, followed by lowercase
(?=[^A-Z]*[A-Z]) # not UPPERCASE, followed by UPPERCASE
(?=\D*\d) # not a digit, followed by a digit
.{8,} # at least 8 characters long
$ # anchor the expression to the end
/mx';
$str = 'strong?
WeaK1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);