import Foundation
let pattern = ##"""
^ # anchors the expression to the beginning
(?=[^a-z]*[a-z]) # not lowercase, followed by lowercase
(?=[^A-Z]*[A-Z]) # not UPPERCASE, followed by UPPERCASE
(?=\D*\d) # not a digit, followed by a digit
.{8,} # at least 8 characters long
$ # anchor the expression to the end
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
strong?
WeaK1234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)