#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[0-9\)\(\s+-]+(\s?(?:x|extension|ext\.)\s?[0-9-]+)?$"
Local $sString = "555-555-5555" & @CRLF & _
                "555-555-5555 x55555" & @CRLF & _
                "555-555-5555x55555" & @CRLF & _
                "555-555-5555 extension 55555" & @CRLF & _
                "555-555-5555 ext. 55555" & @CRLF & _
                "(555) 555-5555" & @CRLF & _
                "5555555555" & @CRLF & _
                "555-5555" & @CRLF & _
                "5555555" & @CRLF & _
                "1-800-CONTACTS" & @CRLF & _
                "1-800-555-5555" & @CRLF & _
                "Hello world" & @CRLF & _
                "(555-555-5555" & @CRLF & _
                "0-999-0349300" & @CRLF & _
                "+43 984-899-46515" & @CRLF & _
                "+43 some bogus" & @CRLF & _
                "939403 03904 aosdf" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")