package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?mi)^[0-9\)\(\s+-]+(\s?(?:x|extension|ext\.)\s?[0-9-]+)?$`)
    var str = `555-555-5555
555-555-5555 x55555
555-555-5555x55555
555-555-5555 extension 55555
555-555-5555 ext. 55555
(555) 555-5555
5555555555
555-5555
5555555
1-800-CONTACTS
1-800-555-5555
Hello world
(555-555-5555
0-999-0349300
+43 984-899-46515
+43 some bogus
939403 03904 aosdf
`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}