import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^[0-9\\)\\(\\s+-]+(\\s?(?:x|extension|ext\\.)\\s?[0-9-]+)?$";
        final String string = "555-555-5555\n"
	 + "555-555-5555 x55555\n"
	 + "555-555-5555x55555\n"
	 + "555-555-5555 extension 55555\n"
	 + "555-555-5555 ext. 55555\n"
	 + "(555) 555-5555\n"
	 + "5555555555\n"
	 + "555-5555\n"
	 + "5555555\n"
	 + "1-800-CONTACTS\n"
	 + "1-800-555-5555\n"
	 + "Hello world\n"
	 + "(555-555-5555\n"
	 + "0-999-0349300\n"
	 + "+43 984-899-46515\n"
	 + "+43 some bogus\n"
	 + "939403 03904 aosdf\n";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}