using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(S[WE]+N)|(N[WE]+S)|(W[NS]+E)|(E[NS]+W)";
string input = @"SNEEESNEEWWNNEENSWWNNWSSWWNNSSSS";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}