re = /(S[WE]+N)|(N[WE]+S)|(W[NS]+E)|(E[NS]+W)/
str = 'SNEEESNEEWWNNEENSWWNNWSSWWNNSSSS'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end