$re = '/(S[WE]+N)|(N[WE]+S)|(W[NS]+E)|(E[NS]+W)/';
$str = 'SNEEESNEEWWNNEENSWWNNWSSWWNNSSSS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);