package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(S[WE]+N)|(N[WE]+S)|(W[NS]+E)|(E[NS]+W)`)
var str = `SNEEESNEEWWNNEENSWWNNWSSWWNNSSSS`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}