package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-z]{2}.sporttu.com`)
var str = `ae.sporttu.com
al.sporttu.com
at.sporttu.com
au.sporttu.com
az.sporttu.com
ba.sporttu.com
badminton.sporttu.com
commonwealthgames.sporttu.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}