import re
regex = re.compile(r"^[a-z]{2}.sporttu.com")
test_str = ("ae.sporttu.com\n"
"al.sporttu.com\n"
"at.sporttu.com\n"
"au.sporttu.com\n"
"az.sporttu.com\n"
"ba.sporttu.com\n"
"badminton.sporttu.com\n"
"commonwealthgames.sporttu.com")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")