re = /^[a-z]{2}.sporttu.com/
str = 'ae.sporttu.com
al.sporttu.com
at.sporttu.com
au.sporttu.com
az.sporttu.com
ba.sporttu.com
badminton.sporttu.com
commonwealthgames.sporttu.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end