import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "lue.*e\\b";
final String string = "[\n"
+ " {\n"
+ " _id: ObjectId('a9eb91254565abcd23452345'),\n"
+ " name: 'Blue Steele',\n"
+ " age: 7,\n"
+ " dogFriendly: false,\n"
+ " breed: 'Scotticshfold',\n"
+ " lastChanged: ISODate('2025-01-01T01:55:47.743Z')\n"
+ " },\n"
+ " {\n"
+ " _id: ObjectId('1234567abcd234556bb71236'),\n"
+ " name: 'Iron Fist',\n"
+ " Age: 100,\n"
+ " breed: 'Orangetabby',\n"
+ " dogFriendly: true,\n"
+ " lastChanged: ISODate('2025-02-12T02:06:38.141Z'),\n"
+ " recordCreated: ISODate('2021-01-01T22:55:52.211Z')\n"
+ " }\n"
+ "]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}