import re
regex = re.compile(r"lue.*e\b")
test_str = ("[\n"
" {\n"
" _id: ObjectId('a9eb91254565abcd23452345'),\n"
" name: 'Blue Steele',\n"
" age: 7,\n"
" dogFriendly: false,\n"
" breed: 'Scotticshfold',\n"
" lastChanged: ISODate('2025-01-01T01:55:47.743Z')\n"
" },\n"
" {\n"
" _id: ObjectId('1234567abcd234556bb71236'),\n"
" name: 'Iron Fist',\n"
" Age: 100,\n"
" breed: 'Orangetabby',\n"
" dogFriendly: true,\n"
" lastChanged: ISODate('2025-02-12T02:06:38.141Z'),\n"
" recordCreated: ISODate('2021-01-01T22:55:52.211Z')\n"
" }\n"
"]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")