$re = '/lue.*e\b/';
$str = '[
{
_id: ObjectId(\'a9eb91254565abcd23452345\'),
name: \'Blue Steele\',
age: 7,
dogFriendly: false,
breed: \'Scotticshfold\',
lastChanged: ISODate(\'2025-01-01T01:55:47.743Z\')
},
{
_id: ObjectId(\'1234567abcd234556bb71236\'),
name: \'Iron Fist\',
Age: 100,
breed: \'Orangetabby\',
dogFriendly: true,
lastChanged: ISODate(\'2025-02-12T02:06:38.141Z\'),
recordCreated: ISODate(\'2021-01-01T22:55:52.211Z\')
}
]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);