const regex = /lue.*e\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('lue.*e\\b', 'g')
const str = `[
{
_id: ObjectId('a9eb91254565abcd23452345'),
name: 'Blue Steele',
age: 7,
dogFriendly: false,
breed: 'Scotticshfold',
lastChanged: ISODate('2025-01-01T01:55:47.743Z')
},
{
_id: ObjectId('1234567abcd234556bb71236'),
name: 'Iron Fist',
Age: 100,
breed: 'Orangetabby',
dogFriendly: true,
lastChanged: ISODate('2025-02-12T02:06:38.141Z'),
recordCreated: ISODate('2021-01-01T22:55:52.211Z')
}
]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}