import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=int|float|String|double|char|long)(?:\\s+[a-zA-Z_$][\\w$]*\\s*)|(?<=\\G,)(?:\\s*[a-zA-Z_$][\\w$]*\\s*))(?=,|;|=)";
final String string = "int a= 100;\n"
+ "float b = 4.5;\n"
+ "long valid_name = 5435435345345\n"
+ "long longest = 453543543543;\n"
+ "char b = 'a';\n"
+ "String str = \"dfssffdsdfsd\"\n"
+ "int d,f,g;\n"
+ "int a,f,frhg = 0;\n"
+ "String string = \"a,b,c,d,e,f\"\n"
+ "int a = 45\n"
+ "long c;\n"
+ "int a, f, f = 5\n"
+ "int a , b , d = 6 \n\n"
+ "float invalid name= 100.10;\n"
+ "int b ^&& = 5\n"
+ "a = d;\n"
+ "String b b b b = \"dfdf\"\n"
+ "double c - 12.454545645;\n"
+ "double d + 56;\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}