# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?<=int|float|String|double|char|long)(?:\s+[a-zA-Z_$][\w$]*\s*)|(?<=\G,)(?:\s*[a-zA-Z_$][\w$]*\s*))(?=,|;|=)"
test_str = ("int a= 100;\n"
"float b = 4.5;\n"
"long valid_name = 5435435345345\n"
"long longest = 453543543543;\n"
"char b = 'a';\n"
"String str = \"dfssffdsdfsd\"\n"
"int d,f,g;\n"
"int a,f,frhg = 0;\n"
"String string = \"a,b,c,d,e,f\"\n"
"int a = 45\n"
"long c;\n"
"int a, f, f = 5\n"
"int a , b , d = 6 \n\n"
"float invalid name= 100.10;\n"
"int b ^&& = 5\n"
"a = d;\n"
"String b b b b = \"dfdf\"\n"
"double c - 12.454545645;\n"
"double d + 56;\n\n\n\n\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.