$re = '/(?:(?<=int|float|String|double|char|long)(?:\s+[a-zA-Z_$][\w$]*\s*)|(?<=\G,)(?:\s*[a-zA-Z_$][\w$]*\s*))(?=,|;|=)/';
$str = 'int a= 100;
float b = 4.5;
long valid_name = 5435435345345
long longest = 453543543543;
char b = \'a\';
String str = "dfssffdsdfsd"
int d,f,g;
int a,f,frhg = 0;
String string = "a,b,c,d,e,f"
int a = 45
long c;
int a, f, f = 5
int a , b , d = 6
float invalid name= 100.10;
int b ^&& = 5
a = d;
String b b b b = "dfdf"
double c - 12.454545645;
double d + 56;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);