use strict;
my $str = 'int a= 100;
float b = 4.5;
long valid_name = 5435435345345
long longest = 453543543543;
char b = \'a\';
String str = "dfssffdsdfsd"
int d,f,g;
int a,f,frhg = 0;
String string = "a,b,c,d,e,f"
int a = 45
long c;
int a, f, f = 5
int a , b , d = 6
float invalid name= 100.10;
int b ^&& = 5
a = d;
String b b b b = "dfdf"
double c - 12.454545645;
double d + 56;
';
my $regex = qr/(?:(?<=int|float|String|double|char|long)(?:\s+[a-zA-Z_$][\w$]*\s*)|(?<=\G,)(?:\s*[a-zA-Z_$][\w$]*\s*))(?=,|;|=)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}