#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "201410[0-3][0-9]"
Local $sString = "20141001" & @CRLF & _
"20141002" & @CRLF & _
"20141003" & @CRLF & _
"20141004" & @CRLF & _
"20141005" & @CRLF & _
"20141006" & @CRLF & _
"20141007" & @CRLF & _
"20141008" & @CRLF & _
"20141009" & @CRLF & _
"20141010" & @CRLF & _
"20141011" & @CRLF & _
"20141012" & @CRLF & _
"20141013" & @CRLF & _
"20141014" & @CRLF & _
"20141015" & @CRLF & _
"20141016" & @CRLF & _
"20141017" & @CRLF & _
"20141018" & @CRLF & _
"20141019" & @CRLF & _
"20141020" & @CRLF & _
"20141021" & @CRLF & _
"20141022" & @CRLF & _
"20141023" & @CRLF & _
"20141024" & @CRLF & _
"20141025" & @CRLF & _
"20141026" & @CRLF & _
"20141027" & @CRLF & _
"20141028" & @CRLF & _
"20141029" & @CRLF & _
"20141030" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")