const regex = /201410[0-3][0-9]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('201410[0-3][0-9]', 'g')
const str = `20141001
20141002
20141003
20141004
20141005
20141006
20141007
20141008
20141009
20141010
20141011
20141012
20141013
20141014
20141015
20141016
20141017
20141018
20141019
20141020
20141021
20141022
20141023
20141024
20141025
20141026
20141027
20141028
20141029
20141030
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}