package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`201410[0-3][0-9]`)
var str = `20141001
20141002
20141003
20141004
20141005
20141006
20141007
20141008
20141009
20141010
20141011
20141012
20141013
20141014
20141015
20141016
20141017
20141018
20141019
20141020
20141021
20141022
20141023
20141024
20141025
20141026
20141027
20141028
20141029
20141030
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}