# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"201410[0-3][0-9]"
test_str = ("20141001\n"
"20141002\n"
"20141003\n"
"20141004\n"
"20141005\n"
"20141006\n"
"20141007\n"
"20141008\n"
"20141009\n"
"20141010\n"
"20141011\n"
"20141012\n"
"20141013\n"
"20141014\n"
"20141015\n"
"20141016\n"
"20141017\n"
"20141018\n"
"20141019\n"
"20141020\n"
"20141021\n"
"20141022\n"
"20141023\n"
"20141024\n"
"20141025\n"
"20141026\n"
"20141027\n"
"20141028\n"
"20141029\n"
"20141030\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.