#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^.*^(GET.*^error[^\n]*)"
Local $sString = "first line" & @CRLF & _
"second line" & @CRLF & _
"GET xxxxx" & @CRLF & _
"GET yyyyy" & @CRLF & _
"GET zzzzz" & @CRLF & _
"Some text" & @CRLF & _
"more text" & @CRLF & _
"error: this is the first error" & @CRLF & _
"" & @CRLF & _
"GET xxxxx" & @CRLF & _
"GET yyyyy" & @CRLF & _
"GET zzzzzLAST" & @CRLF & _
"Some text" & @CRLF & _
"more text" & @CRLF & _
"error: this is the last error" & @CRLF & _
"last line" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")