re = /^.*^(GET.*^error[^\n]*)/m
str = 'first line
second line
GET xxxxx
GET yyyyy
GET zzzzz
Some text
more text
error: this is the first error
GET xxxxx
GET yyyyy
GET zzzzzLAST
Some text
more text
error: this is the last error
last line
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end