# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*^(GET.*^error[^\n]*)"
test_str = ("first line\n"
"second line\n"
"GET xxxxx\n"
"GET yyyyy\n"
"GET zzzzz\n"
"Some text\n"
"more text\n"
"error: this is the first error\n\n"
"GET xxxxx\n"
"GET yyyyy\n"
"GET zzzzzLAST\n"
"Some text\n"
"more text\n"
"error: this is the last error\n"
"last line\n")
matches = re.search(regex, test_str, re.MULTILINE | re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.