package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^.*^(GET.*^error[^\n]*)`)
var str = `first line
second line
GET xxxxx
GET yyyyy
GET zzzzz
Some text
more text
error: this is the first error
GET xxxxx
GET yyyyy
GET zzzzzLAST
Some text
more text
error: this is the last error
last line
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}