using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:[a-zA-Z0-9_.+-/#~]+ ";
string input = @"眼影盤長這樣 http://i.imgur.com/uxvRo3h.jpg 說真的 很不好拍";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}