$re = '/https?:[a-zA-Z0-9_.+-/#~]+ /m';
$str = '眼影盤長這樣 http://i.imgur.com/uxvRo3h.jpg 說真的 很不好拍';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);